Flash

De Le Wiki de debian-fr.xyz
Aller à : navigation, rechercher

Cette page a pour but de vous aider à faire fonctionner le greffon Flash afin de pouvoir lire vidéos et autres animations sur la toile.

Alternative libre

Contrairement à ce que vous pourriez penser, il existe des solutions entièrement libres (donc fiables) afin d'utiliser Flash.

Gnash

Gnash supporte à ce jour très bien les vidéos sur Youtube, et la plupart des animations incluses dans certains sites.

Il supporte totalement la version 7 de Flash, et partiellement les versions 8 et 9. Les versions 10 et 11 ne sont pas supportées.

Installation

Tout simplement, installez le paquet browser-plugin-gnash.

Astuces

Vous pouvez faire en sorte que gnash démarre "en mode pause". Cela vous évite de devoir charger chaque applet Flash sur les pages que vous visitez (entre autre les publicités). Il suffira alors pour la lire de cliquer sur l'animation Flash.

Cette astuce fonctionne avec tous les navigateurs : goodbye flashblock sur firefox :) .

Procédez ainsi : clic droit sur une animation flash -> Éditer -> Préférences. Dans l'onglet "Lecteur" tout en bas, cochez "Démarrer Gnash en mode pause".

Outils pour télécharger les vidéos

Ces outils vous permettront uniquement de télécharger les vidéos, afin de les voir ensuite avec votre lecteur vidéo favori

Chacun d'entre eux s'utilise de la même façon :

nom_du_programme "http://www.adresse-de-la-vidéo.com/"

Alternative propriétaire

flashplugin-nonfree

Comme son nom l'indique, ce greffon n'est pas libre, c'est donc à vos risques et périls que vous l'utilisez. Vous ne pouvez pas connaître les informations qu'il peut envoyer à des tiers sur l'utilisation que vous en faites.

Installation

Installez le paquet flashplugin-nonfree.

Vous aurez besoin pour ça d’avoir au préalable ajouté les dépôts "contrib" au fichier /etc/apt/sources.list.

Utiliser le greffon Pepper dans Iceweasel

Il y a une possibilité de s'affranchir du greffon flash fourni par Adobe et bloqué en 11.2 et d'utiliser le greffon "Pepper" développé par Google.
Il faut pour cela utiliser un greffon (non-off) qui permet l'utilisation de "Pepper" dans Iceweasel/Firefox.
Il n'est pas nécessaire d'avoir Chrome ou Chromium installé.

Pour cela, il faut installer le greffon "Pepper"

# aptitude install pepperflashplugin-nonfree

Ensuite, il faut récupérer le greffon "freshplayerplugin" et le compiler

Les pré-requis

# aptitude install cmake gcc g++ pkg-config ragel libasound2-dev libssl-dev libglib2.0-dev libconfig-dev libpango1.0-dev libgl1-mesa-dev libevent-dev libgtk2.0-dev libxrandr-dev libxrender-dev libxcursor-dev
libv4l-dev libgles2-mesa-dev  libavcodec-dev libva-dev libvdpau-dev libdrm-dev

Pour le support de pulse-audio il faut aussi le paquet : libpulse-dev
Pour le support de JACK il faut le paquet : libjack-jackd2-dev et libsoxr-dev

Vous pouvez ensuite compiler :

# git clone https://github.com/i-rinat/freshplayerplugin.git
# cmake -DCMAKE_BUILD_TYPE=RelWithDebInfo
# make

Les instructions de compilations complètes sont disponible sur le dépot du projet [1]

il faut ensuite copier le fichier libfreshwrapper-pepperflash.so dans le répertoire "plugins" de Iceweasel/Firefox

# cp libfreshwrapper-pepperflash.so ~/.mozilla/plugins/

Si le répertoire "plugins" n'existe pas, le créer.

Vous pouvez ensuite vérifier que le greffon est correctement détecté via le site de Adobe : http://www.adobe.com/fr/software/flash/about/

Notes

Ce greffon a été compilé et testé sur une Debian stretch/sid avec Iceweasel 38.1.0


Sécurité

ATTENTION : Cette implémentation particulière du greffons ne dispose pas des "Sandbox".
Si un code malicieux brise la sécurité du greffon, il n'y a pas d'autre barrière particulière.
C'est le même niveau de sécurité que le greffon NPAPI de Flash

Changer d'alternative

Pour afficher la version utilisée :

# update-alternatives --display flash-mozilla.so
flash-mozilla.so - mode manuel
 le lien pointe actuellement sur /usr/lib/gnash/libgnashplugin.so
/usr/lib/flashplayer-mozilla/libflashplayer.so - priorité 10
/usr/lib/gnash/libgnashplugin.so - priorité 10
La « meilleure » version actuelle est « /usr/lib/flashplayer-mozilla/libflashplayer.so ».


Pour changer d'alternative, il suffit de taper la commande suivante :

# update-alternatives --config flash-mozilla.so
Il existe 2 choix pour l'alternative flash-mozilla.so (qui fournit /usr/lib/mozilla/plugins/flash-mozilla.so).

  Sélection   Chemin                                          Priorité  État
------------------------------------------------------------
  0            /usr/lib/flashplayer-mozilla/libflashplayer.so   10        mode automatique
  1            /usr/lib/flashplayer-mozilla/libflashplayer.so   10        mode manuel
* 2            /usr/lib/gnash/libgnashplugin.so                 10        mode manuel

Appuyez sur <Entrée> pour conserver la valeur par défaut[*] ou choisissez le numéro sélectionné :

Plus d'infos